Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:
  • Seite:
  • 1
  • 2

THEMA: Datenbank wird nicht angelegt

Datenbank wird nicht angelegt 8 Jahre 7 Monate her #2361

  • Robert.K
  • Robert.Ks Avatar
  • Offline
  • Senior Boarder
  • Beiträge: 48
  • Karma: 0
Hallo zusammen.

Ich versuche seit 3 Tagen den CLM unter XAMPP und Joomla 1.5.23 zu installieren.
Leider vergebens.
Alles, was ich versuche endet in der Fehlermeldung

"Fehler beim Anlegen der Tabelle dwz_verbaende"
"Fehler während Anlegen Datenbank.."

1.)Ich habe die Version 1.1.0 heruntergeladen, entpackt und wollte es vom tmp-Verzeichnis installieren. Fehlschlag
2.) Als zip re-packt und als Paket installiert. Fehlschlag.
3.) Alte Version 0.9.7. s.o.

Ich verzweifle langsam.
Ich habe schon das Forum durchsucht, aber leider nichts gefunden.
Bin ich wirklich der erste mit diesem Fehler?

Gruß
Robert
Man hat vom Schach gesagt, dass das Leben nicht lang genug dazu ist, - aber das ist ein Fehler des Lebens, nicht des Schachs. (Christian Morgenstern, 1871-1914)
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Datenbank wird nicht angelegt 8 Jahre 7 Monate her #2362

  • pierre
  • pierres Avatar
  • Offline
  • Administrator
  • Beiträge: 956
  • Dank erhalten: 28
  • Karma: 9
Robert.K schrieb:
Hallo zusammen.

Ich versuche seit 3 Tagen den CLM unter XAMPP und Joomla 1.5.23 zu installieren.
Leider vergebens.
Alles, was ich versuche endet in der Fehlermeldung

"Fehler beim Anlegen der Tabelle dwz_verbaende"
"Fehler während Anlegen Datenbank.."

1.)Ich habe die Version 1.1.0 heruntergeladen, entpackt und wollte es vom tmp-Verzeichnis installieren. Fehlschlag
2.) Als zip re-packt und als Paket installiert. Fehlschlag.
3.) Alte Version 0.9.7. s.o.

Ich verzweifle langsam.
Ich habe schon das Forum durchsucht, aber leider nichts gefunden.
Bin ich wirklich der erste mit diesem Fehler?

Gruß
Robert

das CLM muss nicht entpackt werden. einfach so wie es runtergeladen wurde, unter joomla! als modul installieren. dabei kann die "com_clm_1.1.0.tar.gz" auch lokal stehen. der upload erfolgt als bestandteil der installation. die datenbank als solche wird vorher bei der joomla!-installation schon angelegt. bei der CLM-modul-installation werden nur weitere Tabellen in der DB angelegt.

und damit man nachher vom CLM auch was sieht, ist auch das darstellungs-modul zu installieren.
wenn es dann noch fragen gibt... bin noch ein bisschen drin.

ps: ich würde die frischeste CLM-version nehmen. also die 1.1.4. die läuft bei mir optimal. und da sind auch die neuesten features drin.

psps: wenn es immer noch fehlermeldungen mit der DB gibt, wurde die DB dann bei der joomla! installation auch richtig angelegt? damit das klappt muss joomla! bei der installation/konfiguration auch login und passwort für den DB-zugriff übermittelt bekommen.
d.h. ganz genau genommen, muss die DB schon vor der joomla!-installation als "hülse" kreiiert werden. da geht in einer xampp-umgebung am besten mit phpmyadmin. also im xampp-panel den apache-server und mysql starten. dann in einem browser http://localhost/phpmyadmin aufrufen und dort eine neue DB anlegen. name der DB, login und passwort merken. und dann erst die joomla!-installation. joomla! legt bei der installation schon einige tabellen in der DB an.
ob das klappte oder nicht sieht man an einer fehlermeldung während der installation. dazu am beste auch versuchen die "beispiele" zu installieren. geht das gut, dann hat der zugriff auf die DB funktioniert. dann gibt es bei der CLM-installation auch keine probleme.
bekommt man bei der installation der beispiele während der joomla!-installation fehlermeldungen, macht es wenig sinn weiterzumachen. dann muss man sich die DB nochmal mit phpmyadmin anschauen. existiert die DB? ist login und passwort richtig?
eine rolle spielt ggf. die Kollation. utf8_general_ci ist ganz passend.

und last not least gefragt... welche xampp-version ist am werkeln und in welcher umgebung? windows oder linux als betriebssystem?
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Datenbank wird nicht angelegt 8 Jahre 7 Monate her #2372

  • Robert.K
  • Robert.Ks Avatar
  • Offline
  • Senior Boarder
  • Beiträge: 48
  • Karma: 0
Hallo Pierre.

Zunächst einmal ein Danke dafür, dass du dir Zeit genommen hast.

Zunächst weitere Rohdaten:
XAMPP läuft in der Version 1.7.4 mit PHP 5.3.5
und PHP-Admin 3.3.9.
Das ganze unter VirtualBox 4.0.10 mit WinXP-VM unter Windows 7.
Also genug Potential für Fehler. ;)

Die gleichen Probleme habe ich übrigens auch mit CLM 1.1.4

Die Installation von Joomla verlief problemlos. Die Datenbank wurde problemlos angelegt und mit Daten gefüllt.
Die Installation anderer Module wie z.B. der Font Size Changer funktionieren problemlos.
Was aber ebenfalls nicht funktioniert ist die Installation von CLM als tar-Paket. Da gibt es ein Time-out von Joomla.

Was ich noch nicht getestet habe ist das manuelle Anlegen der Tabellen via SQL-Befehle unter PHP-Admin und der erneuten CLM-Installation.
Da komme ich aber erst frühestens heute abend dazu.

Aber wenn du noch eine andere Idee hast, immer her damit.
Ich würde zu gerne das Modul später einmal auf der HP im Einsatz haben.

Gruß
Robert
Man hat vom Schach gesagt, dass das Leben nicht lang genug dazu ist, - aber das ist ein Fehler des Lebens, nicht des Schachs. (Christian Morgenstern, 1871-1914)
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Datenbank wird nicht angelegt 8 Jahre 7 Monate her #2373

  • Helge Frowein
  • Helge Froweins Avatar
  • Offline
  • Moderator
  • Beiträge: 312
  • Dank erhalten: 4
  • Karma: 4
Robert.K schrieb:
Was aber ebenfalls nicht funktioniert ist die Installation von CLM als tar-Paket. Da gibt es ein Time-out von Joomla.

Das ist meiner Meinung nach der entscheidende Hinweis!
Ich denke, das Tiemout kommt nicht von Joomla (dem ist das egal...), sondern vom Server. Die PHP-Einstellungen sind da schätzungsweise sehr restriktiv, in dem fall sollte es sich um die max_execution_time handeln.
Eine Verdoppelung dieser sollte überlicherweise ausreichen - wenn du deinen Webspace selber adminsitrierst, kein Problem. Ansonsten musst du den Support beknien ;)
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Datenbank wird nicht angelegt 8 Jahre 7 Monate her #2374

  • pierre
  • pierres Avatar
  • Offline
  • Administrator
  • Beiträge: 956
  • Dank erhalten: 28
  • Karma: 9
ja, da muss man nur in der php.ini drehen.
da es ja auf xampp in vm-umgebung läuft (also höchstwahrscheinlich "lokal
"), hat man da alle freiheitsgrade. die "zeit" auf "0" gesetzt - testweise - hülft sicherlich. 0 == unendlich, also kein timeout mehr. im späteren produktiven btrieb sollte man das aber nicht machen, mit der "0". bei fehlern/problememn hängt es da sonst unendlich. deshalb macht ein vielleicht grosses, aber endliches timeout schon sinn. woran es noch klemmen ist das memory-limit (auch in der php.ini zu beeinflussen. interessanterweise macht es da öfter in lokaler umgebung probleme (mit xampp), wie in "reality" auf dem linux-server. auuf dem es sonst beim webhoster oftmals läuft.

erfahrungsgemäss greift diese zeit aber nur wenn man die sache "hochladen" und "entpacken" lässt.

ich denke das DB-gemeckere hat vielleicht doch noch eine andere ursache. aber das werden wir dann sehen, wenn das obige mal versucht wurde.

die php.ini findet sich unter deinem xampp-installationspunkt im verzeichnis php.

interessant ist da dieser abschnitt: mit den werten da drin fährt es bei mir ganz gut:


;;;;;;;;;;;;;;;;;;;
; Resource Limits ;
;;;;;;;;;;;;;;;;;;;

; Maximum execution time of each script, in seconds
; php.net/max-execution-time
; Note: This directive is hardcoded to 0 for the CLI SAPI
max_execution_time = 60

; Maximum amount of time each script may spend parsing request data. It's a good
; idea to limit this time on productions servers in order to eliminate unexpectedly
; long running scripts.
; Note: This directive is hardcoded to -1 for the CLI SAPI
; Default Value: -1 (Unlimited)
; Development Value: 60 (60 seconds)
; Production Value: 60 (60 seconds)
; php.net/max-input-time
max_input_time = 60

; Maximum input variable nesting level
; php.net/max-input-nesting-level
;max_input_nesting_level = 64

; Maximum amount of memory a script may consume (128MB)
; php.net/memory-limit
memory_limit = 128M



und zu den versionen...
ich habe unter vista-xp zb. xampp-win32-1.7.3 am rennen und dadrauf die gleiche joomla!-version die du auch hast. damit geht es prima.

schau mal welche mysql-version mit deiner xampp-1.7.4 mitkommt. es könnte ganz vage sein, diese mysql-version dann schon einen hauch zu hoch ist.

die mysql-version ist allemal kritischer wie die php-version
und es deute ganz darauf hin dass irgendwo da auch das problem liegt.


abba... die ganzen problem hast du ziemlich sicher nicht wenn du das mal auf dem web-provider installierst. da lief es bei mir gleich wie am schnürchen. die lokale installationen musste etwas mehr nachjustiert werden, bis es ging.

eine engstelle könnte auch noch sein, wieviel memory du deinem xp in der vm-umgebung zugestehst. wenn das nicht allzu üppig ist.... windows braucht schon als xp selbst nahezu 1GB wenn man sich nicht stark beschränkt, und fast nix startet. dann kommt noch das dazu was dein apache-webserver in xampp und was php braucht.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Datenbank wird nicht angelegt 8 Jahre 7 Monate her #2375

  • pierre
  • pierres Avatar
  • Offline
  • Administrator
  • Beiträge: 956
  • Dank erhalten: 28
  • Karma: 9
phpinfo zeigt mir bei mysql diese version an:

mysql Client API version 5.1.41
und
Version mysqlnd 5.0.5-dev - 081106 - $Revision: 289630 $
Der Administrator hat öffentliche Schreibrechte deaktiviert.
  • Seite:
  • 1
  • 2
Ladezeit der Seite: 0.076 Sekunden
Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.
Ok